Segmentation Guide using open source resources
By Paul Russell, Ana Carolina Fiorini, and Trevor Caughlin
This guide aims to give you a step by step guidance to digitize tree cover in google earth using
only open source programs.
You will need to download:
-

QGIS
Orfeo

Table 1: Symbols to make your reading easier

Symbol

Meaning
Information about our process/data
Observation about step
Useful web link

1) Download QGIS and get familiar with the program.
1.1)

Download QGIS from: http://www.qgis.org/en/site/forusers/download.html
This Guide was developed with the version QGIS version 2.16.3 (windows) / 2.18.0 (mac). If you are
using a different version, you should be aware that you will find different layouts within the program
that might make it harder to follow this protocol.

1.2)

Get familiar to QGIS.

If you are not familiar with the program, we recommend you to spend some time just
“playing” with the program or watching some YouTube videos about it.
-

https://www.youtube.com/watch?v=aLmMovuydqI

-

https://www.youtube.com/watch?v=OtVpOzLA_NM

-

http://docs.qgis.org/2.0/pdf/

-

http://qgis.spatialthoughts.com/2012/02/tutorial-styling-vector-data-in-qgis.html

-

http://www.qgistutorials.com/en/docs/making_a_map.html

-

http://qgis.spatialthoughts.com/2012/02/tutorial-styling-vector-data-in-qgis.html

2) Installing Plugins and Toolboxes needed to perform the
classification with this guide.
a. Install and open “QuickMapServices” plugin:
Go to Plugins > Manage Plugins > type QuickMapServices >
Install QuickMapServices plugin.
Go to Web > QuickMapServices > Settings > More services > Get contributed
pack
Open the google satellite image:
Web > QuickMapServices > Google > Google satellite.

Figure 1: step 2.a)

b. Install “Image Footprint” plugin:
-

Go to Plugins > Manage Plugins > Settings
Mark the box “Show also experimental plugins”

Figure 2: step 2.b)

-

Go to Plugins > Manage Plugins > type Image Footprint >
Install “Image Footprint” plugin.
Go to Web > Plugins and verify it was installed.

c. Download Orfeo
Orfeo is an open source tool to help users to process remote sensing imagery.
To install it go to: https://www.orfeo-toolbox.org/

Then: Download > Windows > 64 bits
If Orfeo tool box does not load into QGIS When we tried to install Orfeo, you would
try to place Orfeo source files in a different location from the default location. It
seems to be a bug in QGIS but by following the instructions in figure 3 normally fix
the problem. Nevertheless, one of us had to install and reinstall QGIS to get the Orfeo
toolbox.
- Unzip and copy OTB-5.6.1 -win64 folder to C:\qgistools\ after creating it.
- Open QGIS > Processing > options > open provider tab > Open Orfeo tool box (image
analysis) > check “Activate” >
- Set OTB folder values as:
o OTB applications folder = C:\qgistools\OTB-5.6.1-win64\lib\otb\applications
o OTB command line tools folder = C:\qgistools\OTB-5.6.1-win64\bin

Figure 3

Useful web explanation: StackExchange pertinent Q & A
http://gis.stackexchange.com/questions/215153/orfeo-toolbox-for-qgis-not-activatingafter-trying-several-suggestions

3) Creating your Area of Interest (AOI) Polygons.
Before you start to go through this guide you should make sure you have the area of interest
polygons you want to classify. It is important to notice that your data should be in .shp or
.kml format.
Examples of polygons include cadastral data that have properties boundaries, or riparian
corridors that should be easy to create by doing a buffer around the riparian strips.
http://www.qgistutorials.com/en/docs/performing_spatial_queries.html
The examples in this guide were made over the data from the “Azuero Research Project”
that takes place in Panama. The following figure illustrates how the data looks like. The
Azuero’s AOI polygons were riparian corridors.

Figure 4: Data exemplification: Azuero Project data

a.

Creating a Grid in QGIS for AOI

3.1) Open QGIS and add the AOI polygons.
3.1.1) Open your AOI polygons layer:
Go to Layer > add layer > add vector layer > choose your file and click open

Figure 5: step 3.1.2

3.1.2) Create a Grid Vector

Go to Vector tab > Research Tools > Vector Grid.
-Under “Grid Extent” Click the “…” button in the right and select
“Use layer/canvas extent” > select your AOI polygons.
- Under “X spacing”: Choose X values to match your AOI coverage.
- Under “Y spacing”: Choose Y values to match your AOI coverage.
In our case we used: X spacing = 0.025 Y spacing = 0.01
(you may want to try this setting first).
But note that these X and Y values may require several attempts to match unique AOI
coverage.
- Under “grid type” choose “Output grid as polygons”
- Under “Grid” > “Save to file” > name accordingly, e.g. “New Grid”
- you can check the box/click the “open output file after running algorithm”
- press run

Figure 6: step 3.1.4

3.1.3) Select the grid polygons that contain AOI polygons.
- Go to Vector > Research Tools > Select by location
- In the “Select by location window”:
- Layer to select from = your “New Grid”
- Additional layer (intersection layer) = your AOI Polygons
- Click the box of “intersects” under “Geometric predicate”
- Press run.

Figure 7: step 3.1.5

3.1.4) You will now reduce the number of polygons using New Grid and AOI
polygons.
1) Open the attribute table of “New Grid”.
You will see the New Grid records intersecting the AOI are now selected.
2) Click
the Invert selection button.
Right Click on the New Grid > Toggle Editing
3) Delete selected features
4) Click the Toggle Editing button
5) Save the New Grid with now specific grid coverage for the AOI.

1)

2)

3)

4)
Figure 8: step 3.1.6

3.1.5) Depending on the size of your AOI, you will divide the output grid file
in several files to avoid QGIS crashing.
1) Use the “Select Features by area or single click”
button to select the isolated portions of the grid.
2) Open the attribute table of “New Grid”. You will see that the New Grid records intersecting
the AOI are now selected.
3) Click the “Invert selection” button.
4) Right Click on the New Grid > Toggle Editing

Delete selected features
5) Click the “Toggle Editing” button
Save the New Grid with the isolated portions of the grid AOI with a new name.

Figure 9: step 3.1.7

b. Clipping WMS (Google Satellite in our case) in QGIS using a
Grid
Useful web explanation: GIS StackExchange pertinent Q & A
http://gis.stackexchange.com/questions/213054/qgis-export-save-as-image-automatewith-python
4.1.4. Add the Grid shp > right click on it > “Zoom to Layer” :

4.1.5. Go to Project > “New Print Composer”:

4.2)
clipping
WMS in
QGIS using
a grid (Part I Print Composer)
4.2.1. Click “Add new map” button then left click / hold mouse button and draw (drag) from top
left corner to bottom right corner. This places the current QGIS view into Print Composer.

It is important that you make sure all the white area is covered in this step. You will feel
that when you are moving the image it “grips” to the total canvas of the white area.
http://imgur.com/a/HAyhv
4.2.2. To the far right under “Items” tab check both boxes for reference map “Map 0”.
**note** if world files are not produced another “Add new map” step 1 needs to be done and
then checking both of “Map 1” boxes while deselecting “Map 0” boxes will usually fix this bug.
Click on the “Composition” tab > 100 dpi > check box “Save world file” >
Reference Map = Map 0 or Map 1 (depending on the world file bug).

4.2.3. Go to “Item properties” tab > select appropriate scale for your project according to your
AOI sizes.
For Azuero Project we used 15000 as scale, if our suggestion of grid size worked for your
project, you should try with 15000 too.

Check “Fixed Scale” and uncheck “Frame” and “Background”
You will be able to click “fixed scale” after the step 4.2.4

4.2.4. Go to “Atlas generation” tab > Coverage Layer = the Grid > Page name = 123 id

4.2.5. At the top left tabs go to “Atlas” > Export Atlas as Images…
For Window users: go to “Atlas” > Export Atlas as Images…Create an empty folder named
accordingly and select it for the Export > Image format = tiff > Image export options with default
settings > click “Save”.
For Mac users: You just need to select “Atlas” > Export Atlas as Images …has a bug and
sometimes do not show the tiff option. In that case you will create an empty folder named
accordingly, accept the default that will appear and click save. See the type of documents that
show up and convert them to tiff using a web converter.
It is important to create a new folder once there will be many output files.

if your output from this step has lines go to previous step and redo it fixing the gaps
when adding a new map composer

c. Merging the Clips
-

Go to Raster > Miscellaneous > Build Virtual Raster (Catalog)
Settings:
-Check the following boxes:
“Choose input directory instead of files”
“Recurse subdirectories”
“Source No Data” = 0
“Target SRS” = Choose your AOI corresponding target
EPSG:4326 (in our case)

output file

Figure 10: step %

Please see Q & A here: http://gis.stackexchange.com/questions/25499/joining-severalraster-files-using-qgis for further explanations on this step.

5. Separate each .tiff vintage from your .vrt file.
Look at the .vrt image that you have. Probably there are many Images resulting in the
image composite image you have. If this is not the case, jump this step.
You need to separate the different images that are part of your .vrt image into separate
.tiff using new .shp (outlines of the different vintage aerials).
http://gis.stackexchange.com/questions/217774/aerial-vintage-changes-in-onecompiled-raster-how-to-split-it
5.1.1. Create an outline polygon of the .vrt
- Go to Plugins > Image Footprint > Click the folder icon “Image” > Select folder with
the .vrt > Check both boxes > Pick “Valid pixels” > Click “Run”

- The output .shp will be a polygon around the .vrt. After Image Footprint finishes, look for a
new polygon in table of contents named “Catalog.. the date.. ” This is the Footprint (polygon
outline) of the whole .vrt Right Click on it > Save as > VRT_Footprint.

5.1.2. Create shapefiles of the different images.
Go to edit> Footprint > Using the “Split Features” button (in Editor Toolbar) split the polygon
into separate polygons based on each vintage.
Always to start and finish in a point outside the image. Click in the point of beginning, then click
in the points that follow the vintage boundary, then double click outside.
- http://gis.stackexchange.com/questions/46862/how-to-split-features-in-qgis

Save these polygons by right click on it in the table of contents, later adding the dates of vintage
to their names.

5.1.3. Check the date of the image of each polygon in Google Earth.
- open Google Earth, zoom to your image and make notes of the Imagery Dates (this information
is in bottom center in Google Earth layout).
- Alternatively, you can save your polygons as kml and open them in google earth and take notes
of the Imagery Dates

Useful web explanation: GIS StackExchange pertinent Q & A
http://gis.stackexchange.com/questions/217120/loading-historical-googlesatellite-imagery-with-qgis-quickmapservices-plugin

6. Use ORFEO to segment tree Canopies
In this step you will: Clip aerials based on vintage, Orfeo Unsupervised KMeans, Orfeo output
raster tiff size reduction, polygonizing tiff into shp, manual cleanup then into kml final
A) Clipping aerials based on vintage
1. Open a new fresh QGIS session.
2. Add .vrt file
3. Add polygons outlining the aerials based on vintage.
4. Raster > Extraction > Clipper >
5. File name: the vintage date (determined by Google Earth date)
6. Save as type .tiff output “vintage.tiff”

B) Orfeo classification using Unsupervised KMeans
1. Open processing toolbox
2. Type “km” into search
3. Double click Unsupervised KMeans
- under: Available ram (Mb) = 1024
- under: Number of classes = 8
- Run as save output “vintage… kmeans.tiff”

C) Reduce Orfeo output tiff size
1. Raster > Conversion > Translate (Convert Format)
2. Output file = “name… translate50.tiff”
3. Check Outsize = 50%
4. Click the Pencil icon > add “-ot Byte” after “-of Gtiff”
5. Click OK
- http://gis.stackexchange.com/questions/215387/extracting-raster-classes-and-

creating-new-raster-that-is-smaller-in-size-usin

D) Running the sieve tool
1.Type “sie” into Processing Toolbox search
2. Double click “Sieve”
3. Input layer = “name… translate50.tiff” Threshold = 4
4. Output Sieved = “name…sieve.tiff”

E) Polygonize and cleanup using select by expression
1. Open a fresh QGIS session.
2. Add the last tiff created “name…sieve.tiff” ( layer> add layer> add raster layer)
3. Raster > Conversion > Polygonize (Raster to vector)
4. Field name = DN
5. Output file for polygons (shapefile) = “name….polygonize” and click OK.
F) Classify the new polygon shp by DN
1. Right click the new polygon shp > Toggle Editing
2. Right click > Open Attribute Table
3. Click “Select features using an expression” button
4. Field and Values > DN = 7 (or whatever tree class is in your shp)
- To check for the correspondent value of the tree class (or whatever class you are interested),
Use the select feature by area button to choose a feature that you know is a tree; Open Attribute
Table, in the bottom part of the attribute table choose the show selected features, see the value
that you are interested
5. Click Invert selection button
6. Click Delete selected features
7. Toggle Editing > Save

*manual clean up can also be done using the “Reshape Features” tool in an editing session as
needed, just make sure to save updates often.

G) Save as kml and view in google earth
1. Open a fresh QGIS session.
2. Bring in the latest polygon “name….polygonize”
3. Right Click > Style > Outline = Lime Green
4. Outline width = 1.46
5. Right Click > Save vector layer as = Keyhole Markup Language [KML]
6. Check box DN Integer
7. Symbol export = Feature symbology
8. Open KML in Google Earth.

7. EXTRACT INFORMATION FOR THE CLASSIFICATION.

